FFmpeg has been removed from Ubuntu 14.04 and was replaced by Libav. This decision has been reversed so that FFmpeg is available now in Ubuntu 15.04 again, but there is still no official package for 14.04. In this tutorial, I will show you how to install FFmpeg from mc3man ppa. Add the mc3man ppa:

sudo add-apt-repository ppa:mc3man/trusty-media

And confirm the following message by pressing <enter>:

Also note that with apt-get a sudo apt-get dist-upgrade is needed for initial setup & with some package upgrades
More info: https://launchpad.net/~mc3man/+archive/ubuntu/trusty-media
Press [ENTER] to continue or ctrl-c to cancel adding it

Update the package list.

sudo apt-get update
sudo apt-get dist-upgrade

Now FFmpeg is available to be installed with apt:

sudo apt-get install ffmpeg
How to install FFmpeg on Ubuntu 14.04
Tagged on:     

31 thoughts on “How to install FFmpeg on Ubuntu 14.04

  • Permalink

    Thank you very much. I was looking all around stack overflow for a solution to this! Works perfect.

    Reply
  • Permalink

    Thank you so much! Got ffmpeg installed and works perfectly! Cheers!

    Reply
  • Permalink

    Hi,

    I am new to Ubuntu and trying to play my .cpi format videos and convert into other formats to play in other devices.

    I felt this article is very help and follow all provided steps to install ffmpeg codec into ubuntu 14 but when no luck to play my videos after restart to complete installation..

    when i open videos i am getting same error as before install as an error occurred.

    Please help me to how open .cpi format.

    thanks
    Prathap P

    Reply
    • Permalink

      Hello,

      FFmpeg is not a video player. You can use it to convert your media to other formats playable on your device. However, if you explicitly want to play it on your device without conversion, I would suggest you try VLC.

      If VLC cannot play your media, you might try other options I am not conversant about. In short, it (VLC) is the best media player I have ever known. All the best.

      Regards,
      Minda

      Reply
  • Permalink

    Is this going to install the latest version of ffmpeg ?

    Reply
  • Permalink

    How do I sudo apt-get install ffmpeg with libssh enabled?

    Reply
  • Permalink

    Very cool, thanks.
    Initially I didn’t know how to how confidence in your suggested PPA, but then I went to ffmpeg’s main website and found the ppa address from there (which matches what you’ve provided).

    http://ffmpeg.org/download.html

    Reply
  • Permalink

    thankyou so much….
    it worked appropriately…:D

    Reply
  • Permalink

    Like magic, man. Thank you so much!

    Reply
  • Permalink

    Thanks a million man. it worked great

    Reply
  • Permalink

    Wonderful job. Thank you so much. WinFF works again.

    Reply
  • Permalink

    hi

    'This PPA does not support xenial'
    Cannot add PPA: ''This PPA does not support xenial''

    I use Linux/Mint.

    Reply
  • Permalink

    The ‘mc3man’ ppa will allow me to transcode other audio formats to ogg. Even though it has been compiled with ‘–enable-libvorbis’, when you attempt to transcode, it complains that ”-enable-libtheora’ has not been set at build-time. It will transcode to ogg though, but you must set the output file format to snything other than “ogg”. Sloppy.

    Then I tried another ppa – ‘jonathonf/ffmpeg-3’. This build will encode ogg files perfectly. However, for some unfathomable reason, the builder thought it a good idea that spewing 1000’s of lines of realtime encoding data was cool! Do these people actually use ffmpeg?!?!?

    So, still looking for a ‘Trusty’ ppa that does the job properly. I had one before the OS crash, so I know one exists.

    Reply
  • Permalink

    Awesome! helpful

    Suggestion:
    sudo apt-get dist-upgrade -y
    and
    sudo apt-get install ffmpeg -y

    Reply
  • Permalink

    Followed along like a fool and ran dist-upgrade. Now I can’t stop it for fear for corrupting the OS. Lost precious time when I was working on a critical application.

    Reply
  • Permalink

    The following packages have unmet dependencies:
    ffmpeg : Depends: libavdevice57 (>= 7:3.3.4) but it is not going to be installed
    Depends: libsdl2-2.0-0 (>= 2.0.0) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    root@nexonimbu:~#

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

*